Support Phone System Outage
Incident Report for CloudCare
Resolved
This incident has been resolved.
Posted Aug 06, 2020 - 14:19 EDT
Investigating
We are currently experiencing an issue with our phone system provider. This means all inbound calls into our sales and support teams are not connecting. If you need immediate support, please use our chat feature inside of our managed cloud consoles or submit a case via our website. We apologize for the inconvenience.
Posted Aug 06, 2020 - 13:28 EDT