CloudCare payment processing error
Incident Report for CloudCare
Resolved
This issue has been resolved. If you have any further questions or need support for your account, please reach out to your account manager, or send an email to partner@avast.com.
Posted Jul 11, 2022 - 05:45 EDT
Update
We continue to work with our payment processor to resolve the issue with credit card collection for our partners in the United Kingdom. For anyone receiving notification of denial of payment for monthly services, we plan to process these invoices once the issue is resolved with the credit card you have on file.

If you have any questions or need support for your account, please reach out to your account manager or send an email to partner@avast.com.
Posted Jun 15, 2022 - 02:54 EDT
Update
We are continuing to investigate this issue.
Posted Jun 06, 2022 - 15:52 EDT
Investigating
We have identified an issue with our payment processor that is preventing some of our partners in the United Kingdom from completing credit card transactions.

This issue is currently being investigated for a priority fix.

If you encounter issues transacting via credit card, please reach out to your account manager or send an email to partner@avast.com.

We will send an updated notification once this issue has been resolved.
Posted Jun 06, 2022 - 15:51 EDT
This incident affected: DE CloudCare (Payment Processing).