CloudCare US Datacenter Degraded Performance
Incident Report for CloudCare
Resolved
This incident has been resolved.
Posted Mar 13, 2020 - 12:16 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2020 - 11:48 EDT
Identified
We are experiencing performance issues with the CloudCare portal, resulting in extended load times or page timeouts.
Our engineering team is working to resolve the issue as soon as possible.
Endpoint services remain unaffected.
Posted Mar 13, 2020 - 11:39 EDT
This incident affected: US CloudCare (CloudCare Portal).