SMB Technical Support power outage
Incident Report for CloudCare
Resolved
This incident has been resolved.
Posted Oct 29, 2020 - 22:03 EDT
Investigating
We are currently experiencing a power outage in the SMB Technical Support Department. Please be aware that we may not be able to take your calls right away at this time. You can still submit a support ticket and we will answer your questions as soon as possible.
Posted Oct 29, 2020 - 15:31 EDT
This incident affected: Statuspage Notifications (Statuspage Webhook Notifications, Statuspage Email Notifications, Statuspage SMS Notifications).