Degraded Performance
Incident Report for CloudCare
Resolved
This incident has been resolved. All services are operating normally.
Posted 4 months ago. Jun 03, 2019 - 12:07 EDT
Investigating
We are experiencing degraded performance with the CloudCare portal where the customer lists are failing to load. Our engineering team is working to resolve the issue. No endpoint functions are impacted by this incident and will continue to be protected.
Posted 4 months ago. Jun 03, 2019 - 11:46 EDT
This incident affected: US CloudCare (CloudCare Portal).