Unable to download PRC executable for establishing remote sessions

Incident Report for CloudCare

Resolved

This incident has been resolved.
Posted Jan 03, 2025 - 03:40 EST

Investigating

We are currently investigating an issue with Remote Control not downloading the executables for connecting to devices, with both DE and US datacenters being affected.
Posted Jan 02, 2025 - 08:51 EST
This incident affected: Remote Control.