Email Security Services - deferred emails
Incident Report for CloudCare
Resolved
This incident has been resolved, any deferred emails will be sent shortly.
Posted Mar 31, 2020 - 07:31 EDT
Investigating
We are investigating a recurrence of performance issues with Email Security Services, which lead to deferred inbound/outbound emails.
Our engineering team is working to resolve the issue as soon as possible.
Posted Mar 31, 2020 - 06:06 EDT
This incident affected: ESS.