A fix has now been implemented and all new orders are flowing correctly again. For any remaining order issues we kindly ask partners to contact their account managers directly for assistance.
Posted Oct 14, 2024 - 10:03 EDT
Investigating
We are currently investigating a disruption to our billing system in CloudCare. This causes issues with billing, invoicing, the customer list not showing for partners in the CloudCare portal, and services not being added after the purchase. This issue will only affect new license purchases in both DE & US environments. All other services will remain operational.
Posted Oct 08, 2024 - 09:19 EDT
This incident affected: DE CloudCare (CloudCare Portal), US CloudCare (CloudCare Portal), and Billing Services.