Email Security Services - deferred/incomplete emails
Incident Report for CloudCare
Resolved
A fix has been implemented to resolve this issue.
We recommend to re-send those emails which were received in an incomplete state which we have identified to be between 8:45 - 12:45 UTC. Deferred emails are being released and will be received without issue shortly.
Posted Mar 30, 2020 - 12:21 EDT
Investigating
We are investigating performance issues with Email Security Services, which lead to deferred inbound/outbound emails, and in some cases incomplete emails are received.
Our engineering team is working to resolve the issue as soon as possible.
Posted Mar 30, 2020 - 07:06 EDT
This incident affected: ESS.