Billing service interruption
Incident Report for CloudCare
Resolved
We have identified the billing issue within Cloudcare for the UK. This issue is now resolved. If you continue to have any issues or have any concerns, please reach out to our support team.
Posted 3 months ago. Feb 25, 2019 - 13:12 EST
Identified
We are well aware of these billing issues related to the UK CloudCare product, and we are currently working with our business partner to get these billing issues resolved. We will update you with more information as soon as the fix has been released.
Posted 3 months ago. Feb 25, 2019 - 12:27 EST
Investigating
The CloudCare shopping cart is currently experiencing an outage in the UK. Services will be restored as quickly as possible.
Impact:
• Users in the UK are unable to make NEW credit card purchases ONLY.
• All other services remain operational.
Posted 3 months ago. Feb 22, 2019 - 10:08 EST
This incident affected: Billing Services.