Unable to log into portal
Incident Report for CloudCare
Resolved
This incident has been resolved.
Posted 8 days ago. Mar 15, 2019 - 20:57 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 8 days ago. Mar 15, 2019 - 17:48 EDT
Investigating
We are investigating an issue with the CloudCare portal not allowing users to log in. When entering log in information, the portal returns "Incorrect E-mail or Password. Please try again." Please do not try resetting your password using the password reset tool.
We will post an update in 30 minutes.

Impact:
• Users are not able to log into the CloudCare portal.
• All other services remain operational.
Posted 8 days ago. Mar 15, 2019 - 17:28 EDT