Business Hub Upgrade Services Outage
Incident Report for CloudCare
Resolved
This incident has been resolved.
Posted Jun 21, 2023 - 08:56 EDT
Identified
We are currently investigating an issue for those partners currently eligible to upgrade to the Business Hub where the upgrade process is failing.
The upgrade options inside the CloudCare portal will be disabled until the issue is resolved.
Posted May 24, 2023 - 09:14 EDT
This incident affected: Business Hub Upgrade Services.