Reflexion services - comcast.net
Incident Report for CloudCare
Resolved
Reflexion has worked with Comcast to resolve delivery issues that customers had with Comcast email addresses. They are confident that these have now been resolved by Comcast and service to these email addresses has returned to normal.
Posted Nov 19, 2019 - 09:53 EST
Update
Update as of 11/15 08:00 EDT - Reflexion is still working with Comcast to get the issue resolved.
https://tickets.reflexion.net/index.php?
Posted Nov 18, 2019 - 11:27 EST
Identified
Reflexion is currently seeing delivery issues for the comcast.net domain for Email Security Services. Recipients show as being deferred. They are working with Comcast to resolve this issue as soon as possible.
Posted Nov 13, 2019 - 15:25 EST